Crop Module Problem


#1

Hello,
I’ve just starting using the program to count yeast colonies, and I was attempting to run the example pipeline given on the site. However, every time the crop module is reached, I get the following error message:

There was a problem running the analysis module Crop which is number 13.
Image processing was canceled in the Crop module because CellProfiler could not find the input image. CellProfiler expected to find an image named “AlignedCombined”, but that image has not been created by the pipeline. Please adjust your pipeline to produce the image “AlignedCombined” prior to this Crop module.

Stack:
CPretrieveimage in C:\Program Files\CellProfiler\CompiledCellProfiler\CellProfiler_mcr\CPsubfunctions\CPretrieveimage.m (59)
Crop in C:\Program Files\CellProfiler\CompiledCellProfiler\CellProfiler_mcr\Modules\Crop.m (186)
AnalyzeImagesButton_Callback in C:\Program Files\CellProfiler\CompiledCellProfiler\CellProfiler_mcr\CellProfiler\CellProfiler.m (10424)
gui_mainfcn in C:\Program Files\CellProfiler\CompiledCellProfiler\CellProfiler_mcr\CellProfiler\CellProfiler.m (12164)
CellProfiler in C:\Program Files\CellProfiler\CompiledCellProfiler\CellProfiler_mcr\CellProfiler\CellProfiler.m (57)

Any suggestions on how I can fix this or what is causing the error?

Thanks,
Rebecca


#2

Hi,

This just means that CellProfiler is being told to find an image that isn’t there. However, in the ExampleYeastColonies_BT_PIPE, There are two crop modules, and neither refer to the image AlignedCombined, though it is produced in the Align module, so there should be no error even if it were referred to. Did you change the pipeline at all, by clicking any of the popups?

~kate


#3

If I did, I do not know what I changed.

When I load the pipeline I get (in order):
-A notification that some modules have been, and that placeholder text will read “Do Not Use”
-A series of notifications about the settings being based on old versions and that some of the settings possibly being no longer reasonable. Here, whichever option was selected when the window opened is what I kept. It seems likely that the mistake would be here, but, again, if it is, I’m not sure what the correction should be. Module windows are opened for 19 and 20 (ClassifyObjects) and for 12, which is of course Align. In each I get the list of variable descriptions and the list of saved variables.

Beyond that I don’t think I could have changed anything before I attempted to run the pipeline.


#4

Hi,

We realized this was actually a problem with our website- the example pipelines correspond to an older version of our software. We’re fixing it right now, but in the meantime, here is a copy of the newest version of the example Yeast Colonies pipe- that should help you get started with CellProfiler.

~kate
ExampleYeastColonies_BT_Images.zip (1.18 MB)