EditObjectsManually _init_ error


#1

Hello,
When I try to use the module EditObjectsManually after IdentifyPrimaryObjects, it returns with the following error:

Traceback (most recent call last):
File “/Applications/CellProfiler.app/Contents/Resources/lib/python2.7/cellprofiler/gui/pipelinecontroller.py”, line 2839, in do_step
File “/Applications/CellProfiler.app/Contents/Resources/lib/python2.7/cellprofiler/pipeline.py”, line 2089, in run_module
File “/Applications/CellProfiler.app/Contents/Resources/lib/python2.7/cellprofiler/modules/editobjectsmanually.py”, line 195, in run
File “/Applications/CellProfiler.app/Contents/Resources/lib/python2.7/cellprofiler/workspace.py”, line 353, in interaction_request
File “/Applications/CellProfiler.app/Contents/Resources/lib/python2.7/cellprofiler/modules/editobjectsmanually.py”, line 441, in handle_interaction
File “/Applications/CellProfiler.app/Contents/Resources/lib/python2.7/cellprofiler/gui/editobjectsdlg.py”, line 143, in init
File “/Applications/CellProfiler.app/Contents/Resources/lib/python2.7/cellprofiler/gui/editobjectsdlg.py”, line 271, in build_ui
TypeError: init() takes exactly 1 argument (4 given)

Only the error window opens, no processing window where I can edit the objects. Any ideas? Thanks for the help!


#2

Can you give us more information? Your OS, your version of CP, etc? Your pipeline as well would be helpful to troubleshoot if there are issues in the configuration.


#3

Thanks for the reply @bcimini
I am on a macbook pro running OSX 10.12.14 and using CP 2.2.0rc3.
Pipeline is fairly simple, trying to measure C. elegans size (area):
WormAnalyzerNew_small_sizemeasure2.cppipe (7.7 KB)

Thanks for your help.


#4

If you set a guiding image to “yes”, do you still get the error?

In either case, it sounds like a bug, just trying to gather the most information possible before I report. Do you mind uploading an image?


#5

Yes I still get the error with a guiding image.
You can try this one @bcimini


Thanks for your help.


#6

I couldn’t reproduce your error on my PC, but it’s possible it’s a Mac/PC difference thing. I’ve created a bug report based on the info you’ve given me for our software engineers, please keep an eye on that link in case they have any follow-up questions or things for you to try.

Apologies for the inconvenience!


#7

Thank you very much for your help.