Error Processing NamesandTypes


#1

Hi,

I’ve download the nuclear / cytoplasm analysis pipeline “ExampleVitra” and have tried to adapt it for my use. When I run a test I get the following errors. The project is attached.

.20170411_edited_nuclear_cyto.cpproj (871.7 KB)

Traceback (most recent call last):
File “cellprofiler\gui\pipelinecontroller.pyc”, line 2826, in do_step
File “cellprofiler\pipeline.pyc”, line 2067, in run_module
File “cellprofiler\modules\namesandtypes.pyc”, line 1409, in run
File “cellprofiler\modules\namesandtypes.pyc”, line 1461, in add_image_provider
File “cellprofiler\modules\namesandtypes.pyc”, line 1494, in add_simple_image
File “cellprofiler\modules\namesandtypes.pyc”, line 1513, in add_provider_measurements
File “cellprofiler\measurements.pyc”, line 1616, in get_image
File “cellprofiler\modules\namesandtypes.pyc”, line 1988, in provide_image
File “cellprofiler\modules\loadimages.pyc”, line 3212, in provide_image
KeyError: ‘Image’

THANKS!

Jared


#2

I can’t actually try running this without the images (maybe one of your images is corrupted?), but your pipeline loads up fine on my computer. What version of CP are you using, and on what OS? Does it work in your hands if you try doing it with the example images provided alongside the pipeline?


#3

I’ve tried more images using my pipeline and get the same error. The
example images that were provided along side the work fine. I am using CP
2.2.0 (rev ac0529e) on Windows 7 enterprise. Of note, I’ve also tried
running the same pipeline with that same version of CP on my Macbook with
OS X and get the same error.

Thanks,
Jared


#4

That suggests to me that there’s something wrong with your images. If you double click on them in the ‘File list’ window, do they open alright? Are the illumination correction functions the same size as the images you’re applying them to?