Getting CP2 running a batch job on Amazon EC2


I would be happy to try your suggestion, but I’m stuck on an unrelated problem. I’m unable to compile cellProfiler from source.
I went here: CellProfiler Developer’s version installation for Linux
I downloaded the Makefile.CP2:

Then I launched the compilation like that:

I had a lot of outdated libs failling to download. I’ve updated the Makefile with the correct urls.
Now I’m facing this error:

[code]./xconfig -d s /root/soft/cellProfiler/tmp/ATLAS/x86_64/…/ -d b /root/soft/cellProfiler/tmp/ATLAS/x86_64 -Fa alg -fPIC -b 64 -Ss flapack /root/soft/cellProfiler/tmp/lapack-3.3.0/lapack_LINUX.a -Ss pmake ‘make -j4’ -Si cputhrchk 0

ERROR around arg 19 (cputhrchk).
USAGE: ./xconfig [flags] where flags are:[/code]
So I guess I’m not using the correct file/method to build cellProfiler from source and the wiki is maybe outdated.
Please be kind enough to give me any hint to be able to build from source.


I would try using … instead.


I just tested the above patch and can confirm it does indeed solve the problem. I can now initiate an analysis using the “-l” command and everything seems fine. Many thanks for your help.

I am still, however, unable to start an analysis using the “-g” flag as I described in my post above (Thu Feb 06, 2014) and get the same error [ValueError: The grouping keys specified on the command line (Metadata_Site, Metadata_Well) must be the same as those defined by the modules in the pipeline ()]. This isn’t really a problem for me as I was planning to use the -f and -l commands anyways for my analysis, but unless I am doing something wrong, there may be another bug lurking there somewhere that I wanted to bring to your attention.

In any case, thank you again for the patch and all your development work in general!



Hi cscott,
Glad to hear at least one bug is fixed!

As for the ‘-g’ flag, would you first confirm this: if you run with the GUI, does the Groups module report the proper groups when you click the Update button?