HDF5 flush problem


#1

Hi all,

I’m trying to run CP on a linux workstation. CP seems to load fine and the pipeline works in test mode but when i went to analyze, after the first image set, I get the following error:

Traceback (most recent call last):
File “/home/johnfuller/CellProfiler/cellprofiler/analysis_worker.py”, line 422, in do_job
self.cancel_handler)
File “/home/johnfuller/CellProfiler/cellprofiler/pipeline.py”, line 1969, in run_image_set
measurements.flush()
File “/home/johnfuller/CellProfiler/cellprofiler/measurements.py”, line 384, in flush
self.hdf5_dict.flush()
File “/home/johnfuller/CellProfiler/cellprofiler/utilities/hdf5_dict.py”, line 343, in flush
self.hdf5_file.flush()
File “/usr/lib/python2.7/dist-packages/h5py/_hl/files.py”, line 167, in flush
h5f.flush(self.fid)
File “h5f.pyx”, line 105, in h5py.h5f.flush (h5py/h5f.c:1876)
RuntimeError: unable to flush file’s cached information (File accessability: Unable to flush data from cache)

Originally I tried writing to database, and then tried writing to batch file but still had same error. Thanks!

John


#2

Hi John,
I’m guessing a bit here, but I’m wondering whether you have proper access privileges to the temp folder designated by CP. If you look under File > Preferences, you’ll see a preference called “Temporary folder”. Can you confirm that you can read/write to that folder? Also what version of CP are you using?
-Mark