How to merge objects from identifyprimaryobjects and manual identity in output .csv and datafile?



I am trying to optimise a workflow to (semi-)automatically segment chromosomes using DAPI. I have optimised it enough to identify the majority of chromosomes but there are some that are just two close together, which need to be separated manually.

I am wondering whether it is possible to merge the objects identified in primary objects and then a second round of manual into a single output data file and saved image with the object numbers displayed in order?

Thank you in advance,




If you do this in the EditObjectsManually module rather than two separate steps, it should ensure that all the objects are separated and numbered correctly- or am I misunderstanding your question?



Thank you for your help, this has improved my workflow.

Unfortunately, I have another problem. In my workflow I input 6 separate channels in greyscale. I have given them a name and grouped them by the field number. I cannot seem to export a spreadsheet which contains the intensity measurements for each object for each channel. When selecting the measurements to export, on the export to spreadsheet screen, there isn’t an option to select intensity measurements for my desired objects (filtered objects). Is there something I am missing that is simple?

I will upload some images soon.

Many thanks,



Did you run the MeasureObjectIntensity module on your filtered objects? Running it on the original objects wouldn’t work, you’d need to run it on the filtered ones.

Otherwise please post your pipeline for us to take a look at.



Your were right… I used the wrong module, I have now changed it to measure the object intensity, however I have run into a filtering error which is based on overlapping objects? I had to omit sample names due to IP reasons.

Really appreciate your help!




this error only appears after physically using the editobjectmanually module


Can you confirm whether or not you have “Allow overlapping objects” set to “No” in the EditObjectsManually module?

If you do have that set correctly, can you let us know what version of CP you’re running? If you’re running an old version of CP it could be related to a bug that has since been fixed.