Identifying Primary Objects (Nuclei) not working when using "advanced settings"

identifyprimary

#1

Hello,

I am having an issue identifying primary objects (nuclei) using cell profiler. When do not use “advanced settings”, the segmentation is working semi correctly. See image below. One issue is that cell profiler is taking one nuclei and segmenting it into two. I’d like to use the “advanced settings” to edit the smoothing scale and the declumping options in order to remedy this issue.

original%20dapi%20image

However, when I do click on the use “advanced options”, cell profiler more or less completely fails to segment nuclei correctly. Rather is returning segmentation on the cell nuclei and then an additional bit of area which should be easily recognized as background. See image below.

bad%20segmentation%20bad%20segmentation%202

Attached is my pipeline as well.

Nuclei Analysis.cpproj (653.8 KB)

Any help would be greatly appreciated


#2

Hi,

I am a newbie but I would try to check “No” for “Automatically calculate size of smoothing filter for declumping” and test increasing values. This should help decreasing over-segmentation.
Good luck,

Laura


#3

Hi,
I am sending you a correct pipeline. I have used Minimum Cross Entropy thresholding strategy in advanced settings and it works better for segmenting nuclei.

Best
Hamdah

Nuclei_pipeline.cppipe (5.0 KB)