Ilastik IndexError (CP2.2.0, but not CP2.1.1)


#1

I get an error when I try to open an image in Ilastik 0.5:
"IndexError: only integers, slices (:), ellipsis (...), numpy.newaxis (None) and integer or boolean arrays are valid indices"
No image is shown in the Ilastik GUI (it is completely White).

This error occurs for the Ilastik version that comes with CellProfiler 2.2.0, but it works fine for the version that comes with CellProfiler 2.1.1.

Is this a CellProfiler problem or an Ilastik problem?

My OS is Win10 64 bit.


#2

Hi,

Please don’t use built-in ilastik (v0.5) module of CP2.2.0, please download and install newest ilastik 1.2+ from their website http://ilastik.org/download.html

Built-in ilastik only works with older CP release.

Bests.


#3

Actually CP 2.2 should work with ilastik 0.5 on Windows still (though @Minh is right that we’re dropping the bundling of ilastik support within CP, so you may want to consider at what point you want to investigate a new workflow). It sounds like an ilastik error to me, but I think the version of ilastik that came with CP 2.1.1 should still be able to export a classifier that works just fine in CP 2.2.0, but I can’t say for certain.


#4

Hi,

I used for several years different versions of Ilasik 0.5x until the last build 0.5.12 (downloaded from the Ilastik website, not the CP version). I allways had problems (crashes) when going to a newer Ilastik version when I loaded the Ilastik project in a newer Ilastik version. Despite this I never had problems when I used the classifier in diffferent CP versions. I use the same classifiers in both CP 2.1 and CP 2.2.

Regards,
Peter