Incompatibility CP 2.2 vs 3.0 Windows 10



I’m ecountering some problems using the new version of CP 3.0. I know there is little compatibility between older versions and 3.0 and I’m trying to change my pipelines in order to be compatible. When I try to open a project built in 2.2 with 3.0 I’m getting the following errors:

Now the morph module is not including the tophat fuction, so the software is suggesting me to use mathematical morphology modelus instead. Can you tell me exactly where are this kind of functions?

Thank you very much



We actually have a blog post about this later today; I’m sorry for the delay in getting the intel out there! There’s a bug in Morph that’s causing upgrade of certain pipelines to fail; we know about it and are working to fix it for the 3.0.1 release in a few weeks.

The reason that it’s failing is that certain features of Morph got moved to their own modules or deleted from Morph because they were essentially duplicated elsewhere; “tophat” falls into the latter category, since that functionality is contained in EnhanceOrSuppressFeatures “Speckle” option.

You therefore have a couple of different options-

  1. Wait a few weeks to upgrade to 3.0.1
  2. In 2.2, swap out your “Morph” module(s) for EnhanceOrSuppressFeatures; the upgrade should work well then
  3. If you can’t wait for “1” and “2” doesn’t work (or if you also have Morph modules that use settings like “open” or “close”), my workaround would be to save a second copy of my pipline (say as “PipelineName_forupgrade”.cppipe), delete all the offending Morph modules in the copy, then save and open the copy in 3.0.0; it’ll now at least open correctly, and you can look back at your 2.2.0 original to see what functions you need to add back and where.

I’m sorry for the inconvenience!


Hi bcimini,

thank you very much for the quick response! I think I will wait to upgrade to 3.0.1. I’m happy that I worried in vain. I could’t just wait to try the new version.

You don’t have to be sorry.