Particle Counting not detecting particles



As shown by the attached picture, it is detecting the empty spaces between the particles but not the particles themselves.
We have attached our project, we would greatly appreciate your help.


particlecount.cpproj (402.5 KB)


Have you tried running the same after inverting your image? Usually blobs are detected as bright objects in dark background, but here, the particles you’re looking for are dark against a bright background.


I think the advice @pskeshu gave is really good. I would add that, after you invert the image, you can further improve your thresholding by masking out the background material. Also, using the EnhanceOrSupressFeatures module to enhance speckles will improve the signal for each particle.


Hi! Sorry for the delayed response to your help! We tried what you said and looked online for some more help and we have made some progress. The only thing that seems to be in the way is the isolation of each particle. I have the screenshot of the original image and the processed image at the end of the pipeline. I will also attach the original image file and the project in case you need them. How would you suggest we configure it to show us each individual particle?


ParticleCounter_close_ish_07262017.cpproj (462.3 KB)


Can you be a bit more specific about what you need? It seems you’re identifying cells and particles already, so I’m not clear what more you want the pipeline to do.


Sorry, I should have clarified that. We want this pipeline to detect and count the individual particles, but at the moment it seems to be clumping together these particles in some regions. We wanted to know whether it was possible to have these detected as separate particles. Do you know how we could achieve that?


You’ll want to play around with your declumping settings- these are the settings related to smoothing, maxima suppression, hole filling etc in the bottom half of the IdentifyPrimaryObjects module. You can read the help for that module for more information.

You can also try tweaking the settings of EnhanceOrSuppressFeatures to bring out more punctate looking objects, but I’d try fiddling with IPO first.