Problem in installing CP 2.1.1 on Ubuntu 14.04 LTS


i’ve been struggling to downgrade CP to utilize runImageJ module. Since Conda installation doesn’t work (installation itself is successful, but the installed CP somehow doesn’t work properly), I have to start from scratch…

anyway, i git-cloned CP and checked out 2.1.1 release.
then sudo pip install --editable . --process-dependency-links

gives me several error messages that some packages are missing, so I cleared them all by pip installing the packages (pytz, setuptools, numpy, libtiff).

then what I got is this.

File “/usr/lib/python2.7/dist-packages/setuptools/command/”, line 1028, in run_setup

raise DistutilsError("Setup script exited with %s" % (v.args[0],))

distutils.errors.DistutilsError: Setup script exited with error: This distribution is only supported on MacOSX


Can you please paste the full stacktrace?

Have you taken a look at these installation instructions?