Segmenting using masks


#1

Hi Team,

I have the following problem. I need to segment only the nuclei which are surrounded by green tumor dye (here is a link to a sample image (it was too big to just attach it here), please ignore the red channel).

yousendit.com/transfer.php?a … SHpIRGc9PQ

I would appreciate any suggestions.

Regards. Tanya


#2

Hi Tanya,

Attached is a pipeline which might help. Basically, it thresholds the green channel with no segmentation to capture the tissue regions, crops the tissue objects into the nuclei channel and then performs thresholding on a per-object basis to capture the nuclei. You will have to adjust the parameters to optimize the settings for your use.

Hope this helps!
-Mark
2009_07_10_PIPE.mat (1.15 KB)


#3

Thanks

I have modified the Pipeline as you suggested…
However, after a couple of successful runs I have started getting the following messages. I have tried to close CellProfiter and quit MATLAB, the error does not go away. The Pipeline is attached.
Thanks for your help
Tanya

There was a problem running the image analysis. Sorry, it is unclear what the problem is. It would be wise to close the entire CellProfiler program in case something strange has happened to the settings. The output file may be unreliable as well. Matlab says the error is: Undefined function or variable “MaximaImage”. in the IdentifyPrimAutomatic module, which is module #05 in the pipeline.

Stack:
IdentifyPrimAutomatic in /home/tva001/MATLAB/MATLAB_Hellgier/Proposal/CellProfiler_5811Bugfix/Modules/IdentifyPrimAutomatic.m (819)
AnalyzeImagesButton_Callback in /home/tva001/MATLAB/MATLAB_Hellgier/Proposal/CellProfiler_5811Bugfix/CellProfiler.m (4316)
gui_mainfcn in /home/tva001/MATLAB/MATLAB_Hellgier/Proposal/CellProfiler_5811Bugfix/CellProfiler.m (6073)
CellProfiler in /home/tva001/MATLAB/MATLAB_Hellgier/Proposal/CellProfiler_5811Bugfix/CellProfiler.m (55)
ER_PIPE.mat (1.36 KB)


#4

Hi Tanya,

I think this might have been a bug in the 5811Bugfix version which you are using. Try downloading and installing the newest version from the CellProfiler website and see if it clears things up.

One note: When you load the pipeline, you may get some notification windows saying that there may be some module settings which couldn’t be imported and you will need to confirm. Check the module settings both in the changed modules themselves and downstream from the module to make sure everything is consistent.

Regards,
-Mark