Select cell DAPI-positive, Alexa488-negative


#1

Hi,

I have images with two channels, DAPI and Alexa 488. I want to analize cells DAPI-positive, Alexa 488-negative, so i am trying to eliminate the ones left. I read that i could use the module “MaskObjects”, in order to, for example, remove specific objects . However I am not being successful with this. Here is my pipeline. Can someone help me? Thanks!

CellCycleAnalysis_corretilu.cpproj (1.1 MB)
Maria


#2

Hi,
To keep the DAPI positive cells that are Alexa-Negative, you want to tweak your MaskObjects setting just a bit; start with Nuclei_dapi as the thing you want to mask (since those are the nuclei you ultimately want to keep), and mask by Nuclei_Alexa. Everything else looks set correctly.

Good luck!


#3

Hi,

I am afraid that this does not worked! It is not selecting properly the cells DAPI-positive, Alexa 488-negative. I can’t understand what i am doing wrong. Do you knoq another way to do this?

Maria


#4

I can’t test anything here without images and without knowing which cells SHOULD be being filtered (which you’ll be the best judge of). But there are three things you should check, in this order, which will help you figure out what you need to troubleshoot:

  1. Do you agree with what it’s calling DAPI positive cells?
  2. Do you agree with what it’s calling Alexa 488 positive cells?
  3. After it does those two steps, is it throwing out the correct things?

If you can be more specific about what precisely is going wrong, we can be more specific in helping you fix it.


#5

Hi!
I will try to be more specific. These are the pipelines that I am using:

IlluminationCorrection_Alexa.cpproj (701.7 KB)
IlluminationCorrection_DAPI.cpproj (701.7 KB)
CellCycleAnalysis_corretilu_3.cpproj (1.1 MB)

First and second are illumination corrections that I a applied in the third pipeline. I have cells stained with DAPI and Alexa 488. Here there is one example of an image that I am trying to analyze (I can not doanload in here the file because it says that the format is not authorized (.czi), but if you want I can send you by email) :

My objective is to measure just the Integrated Intensity of cells DAPI-positive, Alexa 488-negative. First of all I need to select these cells, and exclude the remaining ones. For this purpose I used the module Mask Image. The image to be masked is the one with the cells I want to keep, so I selected the image with the channel DAPI (Dapi_corr). Then I want to remove the cells stained with Alexa. My mask has to contain the cells I want to remove, so my objects for mask are the nucleis stained with Alexa (Nuclei_alexa), previously identified with the module IdentifyPrimaryObjects.

After this I thought I would obtain an image with cells DAPI-positive, Alexa 488-negative, so I measured the integrated intensity of the cells present in this image. After running the software, I obtained in a folder the image with the intensities, and I realized that the selected cells with the values of intensities are mainly DAPI-positive, Alexa 488-positive and not DAPI-positive, Alexa 488-negative:
DAPIpos_ALEXneg0001.zip (715.7 KB)
Following is an example identified with a white arrow.

I know that the software selected these cells to measure integrated intensity because i used the module DisplayDataOnImage, and these cells have the value of the Integrated Intensity:

If there is something you can’t understand, please tell me. Thank you for your help!

Maria


#6

Hi,
There are two basic workflows you could use to accomplish this task, each of your analysis pipelines you’ve uploaded was close to one of them but just needed one step of tweaking:

Workflow A- (the original pipeline you uploaded in this thread)- Find all nuclei then throw some out if they’re Alexa positive
After correcting illumination, etc-

  1. Use IdentifyPrimaryObjects DAPI image to find Nuclei
  2. Use either IdentifyPrimaryObjects or ApplyThreshold on your Alexa image to find AlexaPositive objects or areas.
  3. Use MaskObjects with “Nuclei” as the objects to be masked (with either the “object” or “image” setting of how you want to mask depending on what option you did in step 2) and Invert the mask? set to yes.

Workflow B- (similar to the _3 version of your pipeline you just uploaded)- Find only nuclei that are not Alexa positive
After correcting illumination, etc-

  1. Use either IdentifyPrimaryObjects or ApplyThreshold on your Alexa image to find AlexaPositive objects or areas.
  2. Use MaskImage on the DAPI image (with either the “object” or “image” setting of how you want to mask depending on what option you did in step 1) and Invert the mask? set to yes.
  3. Use IdentifyPrimaryObjects on the masked image to find your Alexa-negative nuclei.

No matter which workflow you do, don’t just wait to look at the end product to see if you’re getting the results you expect- go into test mode, and look at the output of each module step by step to see if it’s giving you what you expected. If so, go to the next one; if not, that’s the module you know you need to play with the settings of.