TrackObject fails with IndexError, possible bug?


#1

We try to track cells in a time series TIFF stack. Towards the end of the tracking there is an error about an index:

Observed with CP 2.1.1 and 2.2.0 on MacOS X. Do you need the images to reproduce this, or can we somehow help?


#2

Wow, that’s an impressive index! :wink:

Hmmmm, yeah, I think we may need images and a pipeline for that one. Does it happen on every movie or just a particular one?


#3

Microfluidics cytoring-nuclear ratio_trackcytoversion.cppipe (17.9 KB)

Hi,
Attached is a pipeline which emmenlau described that gave the error. If TrackObjects is set to track nuclei it doesn’t give the error, however, if we try to track the cytoplasm it gives the above index error. I have attempted to upload the image file as well but it is not clear if it worked or not (the files are >300MB).

Here’s a dropbox link: https://www.dropbox.com/s/og6m01ttfbg61bm/160603.lif%20-%20A2058FoxoClover_MK_1007.tif?dl=0

Thanks


#4

Yeah, I can reproduce in my hands, with tracking either Cells or Cytoplasm (but not Nuclei).

The bug is in the TrackObjects Distance submodule, so my guess is that other tracking methods will work for you- can you confirm that?

in the meantime I’ve submitted the bug here ; from my preliminary tests it seems to be that Distance doesn’t like Secondary or Tertiary objects, so you could try creating your Cytoplasm objects by using MaskObjects with your cells and nuclei rather than IdentifyTertiary and see if that succeeds.


Error when tracking manually edited objects to a certain image
#5

Thanks for looking at this!

Yes, I can confirm that the error doesn’t occur if I switch to Overlap for example instead of Distance in the TrackObjects module. I have a high frame rate relative to object motion so Overlap works for me, though I will try your other suggestion in order to use Distance.

(apologies for delay, I am new to the forum and assumed it would send me an email if someone responded to my post and then was shocked when I checked now and realized that you responded just a few days after I posted!?!)


#6

No problem, and sorry about the bug! FWIW, you can configure when the site emails you under your preferences :smile:. Happy analyzing!